Remove "Physics" prefix from physics classes?

Dear monkeys, I have a question.

Most of the Physics classes have the “Physics” prefix like PhysicsRigidBodyControl etc. to distinguish the Physics system better from the rest of the SceneGraph. Now that the physics system is no longer based on Nodes thats not really needed anymore and some of the classes have gotten pretty long names due to the added “Control” so I think it might be a good time to get rid of that prefix, so that its just RigidBodyControl. The deprecated nodes would keep their name so people coming from alpha-3 would only find the joints names have changed.

So, what do you think?



I vote for removing the prefix

I vote fore removing “physics” too

Sounds reasonable