Seeking alpha testers for Maud


#41

The new version is working great so far, I did some animation editing and I notice that its even easier now with the improvements you added to the keyframe editor.

I only ran into one bug - I found that the Mesh and Spatial tool caused Maud to crash when I pressed the"select" -> “by name” button to select a child geometry/spatial. I noticed that it only occurs on some of my models though, and not on Jaime. The models are from an asset store, and for some reason the actual Geometry is nested 8 nodes deep after being converted from GLTF (I’m not sure if that may be a contributing factor). But I can manage to select a child spatial if I use the other buttons in the Spatial tool, so itappears to be just the select by name button that causes the crash

Nonetheless, the new version of Maud is working for all my other usual needs, and I’m really liking the new improvements. Thanks for all your work with Maud :slightly_smiling_face:


#42

It’s great to know that Maud is actually getting some use!

I’ll think about what might be causing this. Maybe I can figure it out without seeing the actual model. Does the crash generate a stack trace, by any chance?


#43

Unfortunately not, it just exits out with no error message after the button is pressed. I could upload one of the models if you think that would help.

It is definitely a very useful tool. I started using Maud primarily for the animation re-targeting, but lately I also ran into an issue with some purchased models that had distorted animations, and couldn’t be fixed in blender or even trimmed in the SDK/JMB. But in Maud I was able to import them without any distortion, so you saved me from throwing out non-refundable models :smiley:


#44

If you’re running the pre-built Maud, perhaps you could try building it from source in the IDE and reproducing the crash there?

If that’s inconvenient, send me a private message with a link to the model, and I’ll try this myself.


#45

Hi sgold, I didn’n know about your tool until today and I gave it a try…
Unfortunately no luck :frowning:
I use linux mint 18.3

stepan@stepan-UX32VD ~/Downloads/unpack/Maud/Maud $ ./Maud 
Segmentation fault

#46

I’m a bit out-of-touch with Linux these days, but shouldn’t a segfault generate a core dump? Or if core dumps are disabled, shouldn’t there be a system setting to enable them?


#47

With the glTF file you provided, I had no difficulty reproducing the crash you saw. Thank you!

The crash occurred because Maud requires every Spatial in a model to have a unique name. However, this model contains multiple spatials named "" (the empty string).

When run in the IDE, Maud logs a warning after loading this model:

Feb 12, 2019 7:51:28 AM maud.CheckLoaded cgm
WARNING: model contains multiple spatials named ""

but outside the IDE I’m unsure where such log message go. Devnull, perhaps.

It would be better, I think, for Maud to simply assign arbitrary names to spatials in this situation. I’ll get to work on this change ASAP.


#48

Relying on names for things seems on surface like it may be broken.

JME itself requires no such thing. Even the Node.getChild(name) method makes me uncomfortable because it really should have been findFirstChild(name).

…but yeah, it’s super dangerous to rely on Spatial names because there are no constraints and the models may have them set to specific things for a reason.


#49

The only Linux system I own still runs Linux 1.2.8, so I doubt it will support jMonkeyEngine.

Are there any other Linux users out there who’d be willing to download Maud and see if it runs?


#50

Note: if it matters, many linux distros (I know Linux Mint can for sure) can be run from the boot CD just to try it. I don’t know how well the OpenGL support works in these, though.

Point: if you ever get really frustrated trying to debug some Linux-specific issue then for the cost of an .ISO download, a DVD, and a thumb drive (or just the thumb drive if you want to boot from that), you can potentially run and test Linux things.


#51

I am on Linux Mint 19

While opening the app my laptop freeze. No exception logged in terminal and I need to reboot the system to recover.

Are you using Core profile ?

settings.setRenderer(AppSettings.LWJGL_OPENGL3);

#52

No, Maud doesn’t use that setting.

On my desktop, setting LWJGL_OPENGL3 results in an UnsupportedOperationException. Is this a setting that’s only recommended for certain platforms?


#53

Not sure, mostly it’s recommended for Mac and Linux users which are not using property driver for gpus.
For me running app without setting core profile will produce following exception on Messa driver and LWJGL2 , but works fine with LWJGL3 even without core profile.

SEVERE: An OpenGL error has occured!
org.lwjgl.opengl.OpenGLException: Invalid enum (1280)
	at org.lwjgl.opengl.Util.checkGLError(Util.java:59)
	at com.jme3.system.lwjgl.LwjglAbstractDisplay.checkGLError(LwjglAbstractDisplay.java:136)
	at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(LwjglAbstractDisplay.java:157)
	at com.jme3.system.lwjgl.LwjglDisplay.runLoop(LwjglDisplay.java:197)
	at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:232)
	at java.base/java.lang.Thread.run(Thread.java:844)

Anyway It might not be the case with Maud, because app window opens and I see the monkey model but app froze the system and mouse or keyboard not work.

Maybe we need a third guy to give it a try also to get sure of it.

In case you like, you can upload a Maud build with LWJGL3 without jre bundled, I will test it.


#54

Maud depends on LWJGL v2, so an LWJGL v3 build is a non-trivial task. Also, I’m reluctant to switch to LWJGL v3 because of Issue 942.

How do JME-based games handle this setting? Should I test for platform type and set the renderer based on that?


#55

I just tried it on Kubuntu, and I got the same behaviour. The app opens and I see the monkey, but then the system freezes. After rebooting I found the following error log in the app directory: https://pastebin.com/HsgTR9gw
I hope this helps.


#56

@sgold sounds like a Nifty gui issue ?


#57

Yes. I’m hoping this is just an issue with Nifty 1.4.3 and backtracking to 1.4.2 will fix it.


#58

I’ve uploaded version 1.0.0-alpha.7 of Maud to GitHub. It attempts to address the issues raised so far:

  • For the issue @yaRnMcDonuts raised regarding models from the asset store, code was added to sanitize null, empty, and duplicate Spatial names.
  • For the issues @raistm and @Ali_RS encountered with Linux Mint, the default OpenGL version for non-Windows platforms was changed from OPENGL2 to OPENGL33. In case the new defaults don’t work for everyone, there are new command-line options to override them:
    ./Maud --openGL2
    ./Maud --openGL33
  • For the issue @Toboi had with Kubuntu, I changed the NiftyGUI version from 1.4.3 back to 1.4.2, which is the tried-and-true version for JME 3.2.2 .

I’m eager to hear whether these changes resolve the issues.


#59

Unfortunately I am having the same issue yet.


#60

I can confirm that my issue is fixed :slightly_smiling_face:
(I only tested it with OpenGL 2 though, because my hardware doesn’t support 3.3)