[SOLVED] Error when trying to open Jaime in the SDK

Hi monkeys! I had to reset my computer, and then I downloaded the Jaime monkey again.

The problem is, when I try to import the model to my project. I get a bunch of errors. The same happens when I try to open the .blend file in the SceneComposer and when I manually create the .j3o file.

The two main errors that are filling the output window are:

  • Appending single line not yet supported!
  • Constraint named: ‘IK’ of type ‘Inverse kinematic’ is not implemented and will NOT be applied!

I already tried to load the model in Blender, and it doesn’t look corrupted/damaged.

Here is the complete info from the output window (there was so much text that the forum didn’t let me post the thread XD): http://pastebin.com/Q9QNA1Hx

At first, I thought it was my JME version (still 3.0), but I used the model before. And, since i’m saying that, how do I update my JME version to the 3.1?

Thank you guys, I hope you can help me.


@Kaelthas? Could you look into that?

@Ev1lbl0w Jaime is also directly available as a J3o file in the test-data project.
You can just include the test-data library and load “Models/Jaime/Jaime.j3o”
Or grab the content of this folder jmonkeyengine/engine/test-data/Models/Jaime at 3.0 · jMonkeyEngine/jmonkeyengine · GitHub
and put it in your project’s asset folder in Models/Jaime/

Thanks @nehon! I have only two more questions:

  • How do I update my JMonkey to the 3.1 version?
  • I don’t notice the normals in the model from the test-data lib. I’m using TangentBinormalGenerator, but still doesn’t work. What is happening?


  1. only by pulling it from github and building it yourself. A release is in the work.
  2. Hard to tell, you mean you don’t have the normal map?

Maybe we should take a step back and ask how you expected to notice normals… and then talk about your scene setup.

Nevermind, I missed a thing, it’s working now. Thanks @nehon and @pspeed for your help!