Solved: Installation Stalls on "Configuring Installer" - Windows 7 64-bit

I’m trying to install jMonkeyEngine 3 SDK, using the Windows 64-bit installer. The “jMonkeyEngine SDK Installer” window appears with the message “Configuring the installer…” and the progress bar moves up to about 33% and then stops. I’ve let it sit for hours with no further progress.

I’ve tried re-downloading the installer in case of file corruption and I have also tried the 32-bit installer, but that exhibits the same behavior. There are no error messages or any indication of what it is stuck on.

Is there any way to run the installer in a verbose mode to tell where it is getting hung up?

System Info:
Windows 7 Home Premium, SP 1
Java 7 Update 51
Java 8 Update 73
Java 8 Update 74 (64-bit)
JDK 8 Update 74 (64-bit)

Got it to work! I had to use the --javahome option on the installer to specify the location of my JDK.

Three things to mention here:

a) What happens at that stage is that the bundled jdk is being extracted. Keep an Eye at your cpu/disk usage to see if it really stalls. It should extract quite a few MB here which makes this process slow on slow computers.

b) That means you actually simply skipped that process by using --javahome. It just uses the internal one. This however shouldn’t be necessary since we’re shipping a bundled JDK.

c) See here under Netbeans Installer to see how you can generate a verbose output. It would be really interesting for us devs to see.

However, from your edited post I can see:

Start rollback of jMonkeyEngine SDK(jmonkeyplatform/

So you actually downloaded the 3.0 SDK instead of the latest 3.1 relase? (It should work nevertheless with its bundled jdk)

Great info, Darkchaos!

I did notice that the installer was working for a couple minutes while appearing stalled and was dropping the jdk file out in my Users\AppData\Local\Temp folder, but it seemed to finish after a little while (the file never got larger and the jmonkeyengine installer process was using 0% cpu).

I do wonder if the installer had some sort of issue accessing that folder because mine is actually located on a secondary hard drive (E:\Users\James\AppData\Local\Temp) with a link to it located at the original C: location. Windows 7 was filling up my tiny SSD with fluff and I had to move a lot of important folders over to my larger hard drive including that Temp folder.

I hold onto that Netbeans Installer info for future reference…I should have guessed “–verbose”, but I only thought to try “-v” :stuck_out_tongue:

That is correct that I downloaded 3.0 rather than 3.1–I figured 3.0 was more stable since 3.1 is in alpha.

I’d be curious to run the installer again with the --verbose option to see exactly where it was getting hung up, but now that I’ve got the SDK installed I don’t want to mess it up by reinstalling

Note: You also need --output <file.txt> because the Installer will detach from the Console once you pressed “yes” on the UAC Dialog.
And you can always run the installer and simply close it instead of clicking next.
That way you don’t need to reinstall anything, probably only delete some temp files.