(Solved) Jm3-libraries breaks getDefaultScreenDevice() call

Hallo there,

this might be a simple problem, but i coundn’t find a solution myself. I just downloaded and installed JME 3.0 and tried to run the BasicGame template. But it would not run properly and stop with a return value below 0 (indicating an error). No Exception are thrown.

I managed to narrow down the cause of the problem. If i add the jme3-libraries to the project dependencies the following call causes the problem


Which is executed in the java.awt.Window, which is required for the JME settings dialog. But if I remove the jme3-libraries.jar dependency everything works fine.

Even tried it with Java 7 and Java 8. Both times getting the same result.

Does anyone has a clue how to fix this?

I was able to investigate a little further. The jme3-libraries-terrain seems to cause the problem. I cannot say why though

So, finally fixed it. The problem had nothing to do with the jMonkeyEngine libs. After reading some other seemingly unrelated topics in the forum i found out that the newest nvidia driver causes problems while using opengl and downgrading the driver realy fixed that.

1 Like