[SOLVED] jME defaults to wrong GPU


I just changed PC and got a laptop that seems to have 2 GPUs (honestly not sure about the setup but that’s what it looks like). One of them is an integrated Intel HD 630, and the other is a Geforce GTX 1060. No need to say I would want to run everything on the Geforce … however when launching my usual jME project, I see this at startup:

Dec 19, 2017 12:07:43 AM com.jme3.renderer.opengl.GLRenderer loadCapabilitiesCommon
INFO: OpenGL Renderer Information

  • Vendor: Intel
  • Renderer: Intel® HD Graphics 630
  • OpenGL Version: 4.4.0 - Build
  • GLSL Version: 4.40 - Build
  • Profile: Compatibility

And also when running my usual project, I see the fps is veeeery low (versus my previous pc) which makes me think that the platform is picking the wrong GPU

In device manager, under “Display adapter” I can see two lines, one with the Intel HD 630 and one with the Geforce

I’ve had no other issue whatsoever on other 3D intensive apps (games), they seem to always pick the ‘right’ GPU

What should I do? should I try deactivate the integrated one? any setting you could think of in jME?


Solved :slight_smile:

by forcing the usage of the Geforce, it solved the issue