[Solved] Problems importing from Blender

Hi there,

I am pretty new to jMonkeyEngine, but I love it already.

However, I am having great trouble importing even the simplest blender model into JME. I am using jMonkeyEngine SDK 3.1.0-beta2-b001-SNAPSHOT.

This is an example:

As you can see, the result looks good when imported from an obj file. However, the obj importer combines all meshes with the same material into one geometry, making it impossible to separate the wheels (I want to use it as a bullet vehicle).

The blender importer retains the node hierarchy. However, it looks way different than intended (I am also getting triangulation errors by the way). Also, if I select one of the wheel spatials, the SceneEditor will highlight the correct wheel, but if I select one of the geometries inside that spacial, it will highlight an entirely different wheel. That makes me question if it was imported correctly. This issue arrised after I rotated the model in Blender.

Here’s the original Blender file: blender file

Any help on how to get the model into Blender correctly would be greatly appreciated.


Hope this video help you

You can use Triangulate Modifier in blender. (search the google for how to)
Also you need to remove duplicate vertices. (Select mesh ->Edit mode → Tools panel → Remove Doubles)

Also make sure to look at wiki : https://jmonkeyengine.github.io/wiki/jme3/external/blender.html#toolbar

1 Like

Maybe you are selecting the mesh and the meshes are shared?

As to the other stuff, I can’t say.

Ogre is another path some people use to export models.

Thanks for the swift replies.

I added a triangulate modifier in Blender, but that didn’t change much at first. Then I “applied” it, and the warnings in JME where solved. The model still didn’t look like it was supposed to however. Then, I noticed there an EdgeSplit modifier was also used in Blender. I applied that, and now the model looks as intended.

So, problem solved! Now going to try to apply physics…