[SOLVED ... WATCH YOUR DEPTH WRITE!] Shadows shoot across the scene

Anyone seen this effect before with point light shadow filter?? I can’t seem to remove it. Scene has one point light at the sun location. No other lights in the scene. Tried turning off shadow mode at root node. Still no change.

seems you have some sort of plane geometry on which the shadows are cast. Set the shadow mode of this geometry to none.

1 Like

You are a life saver! My orbit path rings are just a plane with one pixle in the center of the material and scaled so the pixel goes through the planets to create a super fast orbital ring. I tried setting the shadow mode to none on it but did not help. I will remove the geometry and will come up with a better way of showing orbits.

I just solved it. The orbit plane had shadow mode turned off but I was using the point shadow filter not tenderer. The point shadow filter does not look at the shadow mode of spatials but the Depth write flag on the materials. I turned off the depth write (it’s on by default) on the orbit path plane material and all is good in the universe again!!

1 Like