[SOLVED]working with JME3 tutorial 9 no problem on netbeans but on JMP has some

i tried working with the tutorial no. 9 and it works fine on netbeans. when i tried it on JMP it returned an error. i even tried to do a copy and paste the code from the tutorial but even that didnt work. the error was on line 64 saying “java.lang.NoSuchMethodError: com.jme3.bullet.control.RigidBodyControl.getUserObject()Ljava/lang/Object;”

jMP alpha-3 has the libraries as they were when alpha-3 was released, try alpha-4. And next time update to the latest nightly if you want to use that (see the manual).

1 Like

thanks… i removed all the libraries then add those jars i added in netbeans… working fine now…

You dont need to add jars, just use the preconfigured library sets. They can be updated automatically.

i’ll be updating my sdk then test it again.

Just download alpha-4, alpha-3 will take ages to update to the current state.

hmmm… yeah… after the restart there’s another update… 107mb update… ahaha… currently downloading the alpha-4