Textures not rendering on both faces

Hey everyone ,

I have a model I’m using it is a a hollowed out box that makes up a maze. The model renders correct from the outside but when I go into the model the textures do no render and the faces become invisible. The textures render fine inside and out in both deled3d and blender. I’m assuming this is probably due to the normals but I’m not sure how to fix this. Any suggestions ?

Whateva I do what I want.

The default Culling option in 3D-Engines is backface culling(So you can’t see the faces from behind).

You can set it up with:
(mat => Material)

…but note that if you are doing any sort of lighting that the shading will be “backwards” on the back faces since lighting is based on the triangle normals which face towards the front face.

This is why back faces are culled by default since most models that need inside faces will specifically model them.

You can use the Thicken modifier in Blender to thicken up dem walls

Adding the material with culling off worked. However , it made an additional problem. The texture doesn’t wrap probably when it is added to the object manually.

I tried this initially but it didn’t work.


Anyone know why ?

My original model I just copied it scaled down the copy and reversed the edges and vertices that did the trick for rendering however it created a lot of extra faces. Which would take way too long to clean.

@jojoofu said: level.setCullHint(Spatial.CullHint.Never);

This has nothing to do with face culling at all.

If your models are unlit then turning off back face culling may still work for you. But don’t replace the existing materials, just grab them and set the face culling on the existing ones. Otherwise, you will have to make sure you duplicate the material and texture definitions properly.

If your model is lit then you will want to model the inside and outside faces anyway… and then there won’t be a problem with missing faces.

I just used the solidy option for blender. The only down side is all of the extra faces it creates.