Ubuntu x64: Error after run "jmonkeyplatform-linux-x64.sh" script

After download Linux script installer and enable executing with chmod +x, JME3 tells this error: Configuring the installer…
Searching for JVM on the system…
Preparing bundled JVM …
./jmonkeyplatform-linux-x64.sh: 1: eval: /tmp/.nbi-1072635.tmp/jdk-linux-x64.bin: Permission denied
Cannot extract bundled JVM
I have openjdk-7-jre even openjdk-8-jre packages.
Can you help me?
Thanks for any response! :wink:

The SDK comes with a bundled JDK so theres no need to have one installed - so thats not the problem. It looks like theres a file permission issue. Maybe try installing with sudo but then make sure you actually run it with your normal user account.

Thanks for response,
but I don’t think that is a sudo problem - I trying both variants: Install with even without sudo.
Can I send system/hardware details?

I hope so ^^


never install jmonkey with sudo.
If you do, you must manually correct all permissions.

check your permissions for the jdk-linux-x64.bin and post here:
write/read/execute rights

Short mixed (lscpu):

Architecture:          x86_64
    Operační režim(y) CPU:32-bit, 64-bit
    Byte Order:            Little Endian
    CPU(s):                4
    On-line CPU(s) list:   0-3
    Thread to core:     2
    Cores to socket:       2
    Socket(s):             1
    NUMA Units:             1
    Manufacturer ID:           GenuineIntel
    Rodina CPU:            6
    Model:                 60
    Model name:            Intel(R) Core(TM) i3-4150 CPU @ 3.50GHz
    Stepping:              3
    CPU MHz:               1700.097
    CPU max MHz:           3500,0000
    CPU min MHz:           800,0000
    BogoMIPS:              7000.23
    Virtualization:          VT-x
    L1d cache:              32K
    L1i cache:              32K
    L2 cache:               256K
    L3 cache:               3072K
    NUMA node0 CPU(s):     0-3

Or I have to send all output from lshw?

Here are:
-rwxrwxrwx 1 matiseli matiseli 381188096 July 20 11:32 jmonkeyplatform-linux-x64.sh

I am no expert in using the SDK on Linux but why is having the application owned by root an issue when the dedicated settings folder is owned by the user? On most modern OSs thats how things work so that apps executed in the user space can’t modify themselves (e.g. If compromised) or other applications…?

It’s not an issue, as long the user has the permission to execute it.
Usually you give r w x permissions to root and r x to all users.

I’m using kubuntu 14.04 x64 right now, and the installer works fine, can you paste the entire terminal log of all the commands you give in order to install it?

No problem :wink:
Here is my activity monitor:

matiseli@HlavniPC:~$ cd ~/Stažené
matiseli@HlavniPC:~/Stažené$ chmod +x jmonkeyplatform-linux-x64.sh
matiseli@HlavniPC:~/Stažené$ ./jmonkeyplatform-linux-x64.sh
Configuring the installer...
Searching for JVM on the system...
Preparing bundled JVM ...
./jmonkeyplatform-linux-x64.sh: 1: eval: /tmp/.nbi-1075206.tmp/jdk-linux-x64.bin: Permission denied
Cannot extract bundled JVM

PS: I read too that error 1 (but in MatLab app) mean low disk space. Is is not possible:

File system          Size  Occupy Free Oc% Mouted at
udev                 3,9G     0  3,9G   0% /dev
tmpfs                791M  9,3M  782M   2% /run
/dev/sda2             16G  5,4G  9,4G  37% /
tmpfs                3,9G  264K  3,9G   1% /dev/shm
tmpfs                5,0M  4,0K  5,0M   1% /run/lock
tmpfs                3,9G     0  3,9G   0% /sys/fs/cgroup
tmpfs                3,9G   36K  3,9G   1% /tmp
/dev/sda1            441G  190G  229G  46% /home
/dev/sda3            1,4G   72M  1,2G   6% /boot
tmpfs                791M   16K  791M   1% /run/user/1000

ls -ld /tmp ?

drwxrwxrwt 19 root root 540 July 20 17:02 /tmp

On your side everything looks fine to me.

The issue could be within the installer that maybe doesn’t set proper permissions to jdk-linux-x64.bin.
Also, probably the script can find only jdk installations and not openjdk ones, so when this task fails “Searching for JVM on the system…” it try to use the bundled one.

This would explain also because it works with me, since I am using oracle’s jdk8.

But this is just speculation.

Just checked that jdk-linux-x64.bin’s permissions are -rwxrwxr-x, so, this is not the problem.
Then, I have no idea.

EDIT: there is another thing you could check: type mount without parameters and see if /tmp is mounted with the noexec flag

Move script to you home folder and execute it without root permission. I just downloaded script SDK, moved to a custom folder /home/afonsolage/jmonkeyengine and executed the script.

If you have executed it as root before, search for .jmonkeyengine folder on /root or /home/matiseli and remove them.

This should fix all issues.

When people have permission issues that they cannot resolve,
they probably should go for the simple path and install jmonkey for the current user only.
So this is just a good tip for linux beginners.

Of course, as an advanced user, this is a common use case.

Same result…

What you mean by “simple path”? Home directory?

Oh yay, linux builds again :yum:

So I’ve dealt with both of these dependencies on differnent builds, so first, you’ll want to fix your jmonkey.conf file. (I believe it’s in install_dir/etc/ or something similar, there will be among 3 one named .conf.) than change the java home to be wherever your native home is

*This is mine

# ${HOME} will be replaced by user home directory according to platform
default_mac_userdir="${HOME}/Library/Application Support/${APPNAME}/3.0"

# options used by the launcher by default, can be overridden by explicit
# command line switches
default_options="--branding jmonkeyplatform -J-Xms24m -J-Xmx1024m -J-XX:PermSize=128m -J-XX:MaxDirectMemorySize=2048m -J-Dsun.zip.disableMemoryMapping=true -J-Dapple.awt.graphics.UseQuartz=true -J-Dsun.java2d.noddraw=true"
# for development purposes you may wish to append: -J-Dnetbeans.logger.console=true -J-ea

# default location of JDK/JRE, can be overridden by using --jdkhome <dir> switch

# clusters' paths separated by path.separator (semicolon on Windows, colon on Unices)

now give yourself correct permissions form cli

go in, cd to the dir, than just nuke all permission parameters with something like “sudo chmod +x ./*” and let it recursively go through everything. I had to do this since I let it install into /opt.

Paste the output of this command please