Vector3f interpolation

The interpolation methods for vector3f currently act locally so why do they not have the "Local" suffix like the other methods Vector3f math methods?

The old interpolate methods become interpolateLocal.

The new interpolate methods may look like this:

    public Vector3f interpolate(Vector3f finalVec, float changeAmnt) {
       Vector3f beginVec = new Vector3f(this);
       beginVec.x=(1-changeAmnt)*beginVec.x + changeAmnt*finalVec.x;
       beginVec.y=(1-changeAmnt)*beginVec.y + changeAmnt*finalVec.y;
       beginVec.z=(1-changeAmnt)*beginVec.z + changeAmnt*finalVec.z;
       return beginVec;

    public Vector3f interpolate(Vector3f beginVec,Vector3f finalVec, float changeAmnt) {
       Vector3f beginVecClone = new Vector3f(beginVec);
       beginVecClone.x=(1-changeAmnt)*beginVecClone.x + changeAmnt*finalVec.x;
       beginVecClone.y=(1-changeAmnt)*beginVecClone.y + changeAmnt*finalVec.y;
       beginVecClone.z=(1-changeAmnt)*beginVecClone.z + changeAmnt*finalVec.z;
       return beginVecClone;

We should also decide weather it should be lerp or interpolate and ratify the convention.
I like verbose names and I am proficient with auto complete :D so i prefer interpolate.
Where as those who like carpal tunnel prefer lerp, either way we should standardize.
This way new programmers have less surprises.

Makes sense to me!

Hmm, sorry Patmania I may have just shot your idea in the foot with my last sentance  :stuck_out_tongue: