Way to use SceneExplorer without opening SceneEditor?

This is related to my last problem, where my game would crash after reloading my scene.
Basically, scene editor will not open the scene anymore, I don’t know how to fix it, but I do know that my game can still load it the first time.

I’m thinking, maybe there’s a way to edit my scene to delete my terrain from an external editor, or maybe open scene explorer without opening scene editor. i really don’t want to start that scene from scratch, and would rather just remove the sizable terrain.

Which version of jME do you use?

I use SDK 3.1.0-beta2 and the corresponding jME version.

Can you try to open your scene in my editor?

I’ll try, but I need to go to bed soon, and my internet is junk, ETA one hour, when I’ll probably be in bed.

You’r application did not load my world, however, as I was looking through the documentation of the SDK I found out that you can increase the direct memory size (I was increasing heap memory with my application) and now it opens fine. I’m sure that your editor would work just fine if I increased the Direct Memory.

Wiki Solution Page: https://jmonkeyengine.github.io/wiki/sdk/increasing_heap_memory.html

How much direct memory do you use?

Judging by this thread, over 4GB

You need to learn how to add and remove parts of your scene in sections. And then how use level of detail. It’s the only way…

Yeah, but he was adding heap memory and not direct memory… so it wasn’t actually fixing anything.

# ${HOME} will be replaced by user home directory according to platform
default_mac_userdir="${HOME}/Library/Application Support/${APPNAME}/3.1.0-beta2-b001-SNAPSHOT"

# options used by the launcher by default, can be overridden by explicit
# command line switches
default_options="--branding jmonkeyplatform -J-Xms24m -J-Dsun.java2d.dpiaware=true -J-Dapple.laf.useScreenMenuBar=true -J-Dawt.useSystemAAFontSettings=lcd -J-Dswing.aatext=true -J-Xmx1024m -J-XX:MaxDirectMemorySize=4098m  -J-Dsun.zip.disableMemoryMapping=true -J-Dapple.awt.graphics.UseQuartz=true -J-Dsun.java2d.noddraw=true"
# for development purposes you may wish to append: -J-Dnetbeans.logger.console=true -J-ea

# default location of JDK/JRE, can be overridden by using --jdkhome <dir> switch

# clusters' paths separated by path.separator (semicolon on Windows, colon on Unices)

This is my config. As the direct memory was set (by default) 4 times the heap memory I increased heap memory and then increased direct memory accordingly.

``-J-Xmx1024m -J-XX:MaxDirectMemorySize=4098m ```

I’m sure I’m overkilling this but oh well :stuck_out_tongue: not like I’m setting this for the games, only the IDE. And as I said in the other thread I’m just going to stay away from large terrains.