Another animation thread

I’ve spent at least 3 days of my easter holidays trying to figure out how to get the animations working right on my character. I’ve followed the documentation, turned Envelopes off on the modifiers and the armature in blender and put all the animations into the NLA editor, but when i export i just get one animation called my_animation in the AnimControl, which just makes my mesh spaz out. Please can anyone help me get it working? Thanks.

when you export, make sure you dont have a red active animation in NLA and have all yellow ones in one track(i mean in line one by one) also each yellow one need to be good configured.



btw you have 2 youtube tutorials about it. so look at both.

additionally do you have a root bone at 0,0,0? do you apply transforms (i believe it is called control-A when your mesh is selected in object mode) to the model



here is one of the vids i found very useful…

https://www.youtube.com/watch?v=QiLCs4AKh28

Yeah thanks I watched that guy’s tutorial too but when i make a root bone the other bones go in a wierd shape when i tab out of edit mode ? :confused: He didn’t actually show how to set up the bones with a root bones. Also, do the animations all have to be in the same track in the editor? i put them on the same line but not the same track…

This topic should help:

http://hub.jmonkeyengine.org/groups/import-assets/forum/topic/blender-2-61-animation-issues/?topic_page=2&num=15



Working model:

http://dl.dropbox.com/u/26887202/123/jme_blender/characterOgre26.zip



Working project:

http://code.google.com/p/rise-of-mutants/

Also, see this post at last paragraph.

So is the root bone supposed to be a different armature? i’ll have a look at the model

@glaucomardano said:
Also, see this post at last paragraph.

you mean Normen? yeah i tried converting it :p
@javagame said:
you mean Normen? yeah i tried converting it :p


No, before that :P.

Right, I didn’t know about parenting all the bones I’ve just been extruding them, but one more thing : how do you set the root bone to (0,0,0) the video said ctrl + c but that doesnt work for me?

clear location? alt+g.

right :slight_smile:

@javagame said:
So is the root bone supposed to be a different armature? i'll have a look at the model


No it is all the same armature... parent all the other bones to this root bone.. You don't have to move the other bones though, do an "offset" when you parent (parent is ctrl + P) where i think the last bone you click will be the parent (higlighted brighter) and all the others selected will be children, and it should keep them in the same location as they were

Wait, you are supposed to parent every bone directly to the root bone? I’ve just finished making and animating a new armature for it like on Mifth’s model, i parented one bone to the root bone, then like 4 bones to that then two to the next one & so on… I’ve had a little more success than before, both the animations come up in the Animcontrol now, the Stand one works but the Walk one deforms the mesh. At least it’s moving this time. If it would help I can post the model…?



Edit: here is a screenshot of the way it is rigged up: http://imgur.com/preYC, you cant see the root bone but the middle bone is a child of it

Shameless self bump. :confused: the mesh is still deforming :confused: ugh

@javagame said:
Shameless self bump. :/ the mesh is still deforming :/ ugh

wtf, not even an hour? :x

ok that rig just looks …well weird…plus is that the entire rig seen in the pic:? how about a pic with front and side views with the bone names turned on…also are you sure all vertices are weighted to a bone but again that …rig looks weird…among other things

@javagame said:
how do you set the root bone to (0,0,0) the video said ctrl + c but that doesnt work for me?


Shift-c puts the 3D cursor at the origin (0,0,0). Then, shift-a to add the root bone, at the position of the 3D cursor... which will be at the origin.

I think the author of the video meant shift-c, not ctrl-c.

Sorry @normen, I get bored quick :stuck_out_tongue: @mcbeth http://imgur.com/UECeQ Sorry some of the bones are’nt named the naming thing in the outliner just gave up on me half way through naming :confused: & the rig is dodgy because i’m crap at rigging (well pretty much all of blender actually, as you can see :p) And I have to work around the clothes.

@javagame said:
Sorry normen, I get bored quick :p

How's that possible when theres so much to learn? :P
1 Like