Fbx to blender to J3o seem colapse

Well not certain but from your style it looks like you’re not using the latest sdk? (Or did you manually switch to the legacy style?)

We’ve had many fixes and the engine had as well, so maybe it helps a bit.
If not The problem for me is that I have no clue what could become wrong so the engine crashes :confused:

Are you with me?
I am using SDK alpha 5 . soon going to update to beta 1.
I created those videos using alpha 2.

I know that, but you don’t have the “brown” darkmonkey either,
I didn’t talk to you but to @SimonBedard with that

Oops! :blush: Sorry for getting it wrong.

1 Like

So I did just put it up to date and yet I still have the same problem. I have it on an other model too. It felt like the model is collapsing. If I remove the bones I get the model okay, but I kinda need the animation :confused:

Maybe @Kaelthas (The Blender Guy) can have a look, if you give him your .blend and .j3o.

This will take some time though, since he’s a busy man :stuck_out_tongue:

Did the workaround from Ali help a bit (the exception should be fixed by using your own material)?
Maybe you can set the CullHint for the Bones Geometry?

Well ya, worked whit it but still can’t seem to make the model work :confused: . At lest I know how to bake a animation now, so as soon as my bones problem is gone it should be a lots of fun :smiley:

How are bones calculated in JME anyway? Cause this is now a 100% bone problem :confused:

So i still can’t seem to find what is wrong :confused: Does anyone had the problem befaure?

never had any issues going from blender to jme… can you post your blender file, or even better, a simple test case file that suffers the same problems ?

Here is the link to both the fbx and the blender i made out of it. I know the animations are not yet bake, thas a problem for later, but for now i want the bones to work and i just can’t seem to do it :confused:

Hi @SimonBedard

here is your model correctly imported from blender to JME :

I edited your blender. You can download it here
You can simply convert it to j3o in SDK.

In your case applying “Scale” of armature to “1” was not useful because scale data were set in key frames and it was 0.01 so i set scale to 1 across all key frames using
this script in blender:

import bpy

scale = 100 #change this value  'scaling factor'

for action in  bpy.data.actions :
    for fcurve in action.fcurves :
        if fcurve.data_path == 'scale':
            for p in fcurve.keyframe_points :
                p.co[1] *= scale

I will add a new video tutorial about this problem soon, maybe this weekend.

2 Likes

Just a question: You talk about video tutorial are those tutorials available in the wiki somewhere? If not wouldn’t that be a good idea?
I only worked once through the tutorial going via the ogre plugin. But it seems now it is possible to import directly from blender without big troubles.

Man you are a life saver! Thanks! I knew someone who knew what he was doing could do it :smiley: ! The pipeline is now open x)! Well, when I actually fully underthant what all that scaling mean x)

Anyway thanks you so much!

Edit : I can also see that your anim control is in the same file as the model and the skeleton, something i could not do. How did achive that?

1 Like

You’re welcome.

I just baked animation in blender.

They are not in wiki but in forum:

If people think those tutorials are good enough to put on wiki, then for sure I will do that :slight_smile:

1 Like

Hey, i do not have access to the blender file, could you send me an authorisation? The mail is JavaKhanStudio@Gmail.com :smiley:

oops! really sorry about it.
I turn on “sharing for everyone” on it. please check the download link again.
or here: https://drive.google.com/open?id=0B35eWZpi0dBoc2V3bUtvOS00ZjA

could you download it ?

Yep, and its working perfecly. Thanks, i’ll try to emulate that for all the models and animation!

Hey quick question, is it normal that i can’t apply a texture on the model once its imported? Cause right now if i put any material on it does display it, but block the animation and disapear next time i open the model. Also don’t seem to accept when i apply it direcly in-game :confused: