How to load an animated Cadnav model into jME3?

Several weeks ago I posted this question asking if there were any good open source 3D model repos out there, with models already rigged with animations.

The individual who provided the excellent answer to this question referenced a model at and mentioned that I could download an animated version of it off of Mixamo.

However when I go to Mixamo I don’t see that particular model listed anywhere. So my first question is: how can I find an animated version of this model off of Mixamo, or anywhere else? Also, how can I obtain a list of all the available animations on this model?

I tried downloading the un-animated model directly off of CadNav (first link) but my browser downloaded a prontovideoconverter_1.0.29-2.safariextz file and I have no idea how to load it with assetManager.loadModel(...)any ideas? Thanks in advance!

Here I exactly mentioned that most of the models in created in Autodesk 3DS Max so you need to have 3ds max to open them.

CadNav models are not available in mixamo you need to upload them to Mixamo yourself then mixamo will rig and animate it for you. Are you sure you watched part 1 and part 2 of my tutorial ?
in part2 i upload the model to mixamo and animate it .

go to this link

click download button

it will redirect you to other page :

it is in .rar file format.

If you do not have 3ds max you can not use models from CadNav. So I suggest you to use Mixamo’s free human models instead and download them in .fbx or .dae format and import them directly to blender then save as .blend format and convert it to .j3o. i showed those steps in part3 of my tutorial.


I animated and converted the model to .j3o format you can download the zip here :

Unzip it inside your Models directory to have textures import correctly. so the directory path should look like: assets\Models\Models\Players\Jo Sang\cadnav.com_model\Jo Sang

Edit2: If you are new to JME and you are in your learning path and just want to test and learn how to work with animated models in JME i highly recommend to use simple animated models which are available in jme3-test-data.jar .
and do not use complex models from cadnav or mixamo.

Makes perfect sense @Ali_RS - thank you so much!

Hi @Ali_RS - quick question! I am (obviously) brand new to Blender. When I open it up, there is a cube rendered at the origin (0,0,0). I am trying to figure out how to remove it.

I am on a Mac laptop. According to Google, I can remove it by:

  1. Selecting the cube by clicking on it
  2. Issuing a “RMB” (Right Mouse Button) click
  3. Entering the “X” key
  4. Selecting the “Delete” option from the subsequent popup

So I click on the cube, then I press & hold the Control key on my keyboard, and then I click the mouse pad (this is the Mac laptop equivalent as a right-click with an actual mouse). I then press “X” and see the “Delete” popup. I select the “Delete” option, but nothing happens!!!

Any ideas?

It is important for me to do this because I have already downloaded all my animated models from Mixamo and now I am trying to load the first one into Blender, but the cube is drawn “over” most of my model!

I have never used mac.
In windows i just select object and hit “Delete” key from keyboard.
I googled it and found this settings for mac :

also make sure to be in “object mode” in blender:

Thanks @Ali_RS, your screen shot is proving to be very helpful here!

I am in “Object Mode”, however when I click on the cube, I do not see its borders outline in orange.

All I see is the bullseye/target, but the cube is definitely not actually selected. In your screenshot, once you clicked the cube it surrounded the cube in a thin orange border - mine does not. Any ideas here?

I don’t have a mac, but found this on the web:

"Open up Preferences, Switch select to Left Mouse Button. That’s pretty much imperative on a mac.

Blender assumes by default that you’re using a 3+ button mouse, which is a little bit silly and unrealistic. So the default keybinds are very unfriendly to mice with only 1 or two buttons."

you can select it like below :

Yah, I thought of that, but you can’t do anything in blender if you can’t select vertexes, edges, faces.

Thanks to both @Ali_RS and @loopies!

Both solutions worked for me! Thanks again for all the help! Onwards and upwards with @Ali_RS’s tutorials!!!

1 Like

Explains how to use a normal mouse under mac. I suggest you buy a cheap 3 button mouse ^^.
I bought mine for 1 euro at a second hand store :D.

Blender wants a 3 button mouse. If you don’t want to go nuts, buy one ^^.

OK @Ali_RS a few more questions about your (most excellent!) tutorials:

  • Part 2 - How to call up the magical menu at 9:21 that allows me to add a Lamp >> Hemi?
  • Part 3 - is adding specularity/hardness/intensity necessary? I understand alpha/transparency is necessary, but these other items seem to only be used for making the model look more realistic in jME.

Any thoughts?

Or just use “Shift+A” button.

No they are not necessary.

I am so glad that you like my tutorials.:grinning:

Thank you - and yes your tutorials are great!

I’m using Mixamo’s “Big Vegas” (Elvis) character with ~10 or so animations in a dummy game I’m making, just to get used to jME and gamedev.

Also, +1 to the idea of jME maintaining its own Model Repo, whether its free, for-pay, or both. I think it will help foster much better adoption for newcomers who have previous programming/JVM experience, but who are totally clueless + inept on the art side of gamedev.

As long as it was reasonably priced/licensed, I would pay to have all my models rigged & animated for me, so I could just “drag n’ drop” them into my jME game, and spend my time focussing on the code!

Thanks again!

Hi @Ali_RS,

So I have some time today to keep going with your tutorials.

I created an account on Mixamo and downloaded a Big Vegas character animated by the Neutral Idling animation and saved the character as bigvegas.fbx. On Mixamo he looks like this:

I then opened Blender, and imported that FBX (and yes, I made sure to check the “!EXPERIMENTAL! Apply transform” checkbox.

When the character loads, all I see is:

However, if I just import him without checking that “!EXPERIMENTAL! Apply transform” checkbox, he imports like this (basically normal):

Do you know what’s going on here? Should I proceed forward without the “!EXPERIMENTAL! Apply transform” checked? Is there something else I can do to get “!EXPERIMENTAL! Apply transform” working? I’m on a Mac 10.10.5 if that helps…please advise!

If it works OK , then simply ignore !EXPERIMENTAL! Apply transform. I think there will be no problem so nothing to worry.
and continue the rest of steps normally.
thanks so so much that you informed me about this.:slight_smile:
And if any problem occurs in any of steps please let me know about the issue.

Hi @Ali_RS I’m running into all sorts of problems with my model and quite frankly I’m running out of time! I think your tutorials are excellent however I think there’s just something advanced+technical that I’ve overlooked or that was different with my Mixamo model to begin with.

I just want to start playing around with jME3! Do you know of any j3o models that are already rigged + animated that will just magically load into my jME3 app? I just need something that looks human-like and can do a few various useful animations (idle, punch, kick, jump, etc.) but at this point I won’t be picky! Thanks for any-and-all-help here!

Yeah, look for Jaime in the test data. He’s an animated monkey that does all those things.