I was also wanting to get a gamepad remapper overhaul in for this, but no one has really commented on my post, so I’ve held off on a PR for now. Of course, I probably should also add those fixes for #1466…
I tried to build v3.4.0-alpha2, but “apt-get update” failed for reasons I don’t fully understand: (logfile)
Reading package lists...
E: The repository 'https://download.opensuse.org/repositories/devel:/kubic:/libcontainers:/stable/xUbuntu_18.04 Release' no longer has a Release file.
Error: Process completed with exit code 100.
Perhaps it was a transient issue. I’ll try again later.
Edit: v3.4.0-alpha3 has been released. It’s available from GitHub, Bintray/JCenter, and MavenCentral. So far, the only issue I’ve noticed is that the BinTray version is missing one checksum file (out of 68). Since alpha3 is probably JME’s last release to Bintray/JCenter, I’m not motivated to solve this issue.
I’m pleased to note that the MavenCentral version includes jme3-testdata, which was never made available from JCenter. Having all 17 libraries available from one Maven repo should prove very convenient.
I just donwloaded jme3.4-alpha3 and I realized that there’s jme3-lwjgl3 (and its dependencies) missing in the package although the sources are included. I don’t know if it’s the intended behaviour or it’s just missing by mistake
I’ve plugged 3.4.0-alpha3 into both my games. No issues so far but I’ll continue to run with this version and see if anything comes up. Qualitatively the performance felt the same.
Areas my games covers:
Gradle Build
Desktop (jme3-desktop)
SimpleWaterProcessor
WaterFilter (Obviously different game from SimpleWaterProcessor)
Custom Meshes
Shaders (as in written by me, not just the built ins)
JavaFx integration (used for menus etc)
Picking
jme3-lwjgl3 (I didn’t seem to have the problems joliver82 experienced)
The zipfile contains an executable version of the JME test chooser. The executable shouldn’t contain both the jme3-lwjgl library and the jme3-lwjgl3 library because they contain conflicting classes (in the same way the jme3-bullet and jme3-jbullet contain conflicting classes).
I read that thread some time ago but I didn’t follow it till the end so I just assumed that having passed so much time everything would have been fixed and default changed to lwjgl3
Hello everyone,
would it be possible to add the getter and setter methods for the fieldOfView parameter of the Camera.java class to make it easier to read and write?
public void setFieldOfView(float fov) {}
public float getFieldOfView() {}
something like that so you don’t have to use a wrapper class like in the example?
public class MainCamera {
private Camera cam;
private float fieldOfView;
private float near;
private float far;
/**
* Creates a camera state that will initialize the application camera to a
* 45 degree fov, 0.1 near plane, and 1000 far plane.
*
* @param cam
*/
public MainCamera(Camera cam) {
this(cam, 45, 0.1f, 1000); // 45 is the default JME fov
}
/**
* Creates a camera state that will initialize the specified camera to the
* specified parameters. If the specified camera is null then the
* application's main camera will be used.
*
* @param cam
* @param fov
* @param near
* @param far
*/
public MainCamera(Camera cam, float fov, float near, float far) {
this.cam = cam;
this.fieldOfView = fov;
this.near = near;
this.far = far;
resetCamera();
}
public void setFieldOfView(float f) {
if (this.fieldOfView == f) {
return;
}
this.fieldOfView = f;
resetCamera();
}
public float getFieldOfView() {
return fieldOfView;
}
public void setNear(float f) {
if (this.near == f) {
return;
}
this.near = f;
resetCamera();
}
public float getNear() {
return near;
}
public void setFar(float f) {
if (this.far == f) {
return;
}
this.far = f;
resetCamera();
}
public float getFar() {
return far;
}
private void resetCamera() {
float aspect = (float) cam.getWidth() / (float) cam.getHeight();
cam.setFrustumPerspective(fieldOfView, aspect, near, far);
}
}
A minor report.
Error writing initTogleRotateInput method name, missing a g
To keep this topic focused on the upcoming release, suggestions like these should go elsewhere: either as new issues/PRs at GitHub (best for long-term tracking) or as new topics here at the JME Forum (best for discussion).
No need to track or discuss renaming initTogleRotateInput(). I’ll take care of it.
i will also invest some extra time in fixing AndroidHarness rather than deprecating.
this is my first time to do a pull request to jme ,so if i had made something wrong , or non-acceptable , please let me know , i will happily undo the change.