LODs causing holes in Geometries

When I use the LOD generator in the scene composer, instead of reducing the number of triangles and vertices, it looks its just reducing geometries by removing random triangles and their faces, leaving triangular holes in my models at even the smallest level of detail. I looked through the LOD tutorial again and tried reducing a few different geometries by code with the LodGenerator’s .bakeLods() method using all 3 reduction types and I got the same results.

here’s a screenshot of what’s happening. Right now i’m using my high poly version until my friends helping with graphic design finish learning baking and normal maps, so you’ll probably notice the obscene triangle and vertex count, but if you notice the stomach is where I’m having problems and I tested that part of him since the triangle/vertex count for just his stomach is only 700-800 : when hes in high detail form he looks exactly the same except his stomach doesn’t have missing triangles, so it’s like the levels of detail aren’t resulting in a low poly geometry, its just removing polys from the initial one.


Does anyone have any idea what may be causing this? I thought it may be a version issue but I had the same issue when i tested it on my other computer running 3.1.0 and got the same results.

Hmm… Maybe your model has duplicated vertices, faces or something…
If you use Blender you could try the following:
Select your model in Edit mode. Under “Tools” you can find the option “Remove Doubles”. Click and see if something has been optimized / removed. If so, export your model to JME again and try again to generate LODs.

I gave that a try and then I also made a simple test polygon with 1000 triangles and I got the same issue. I did have some doubles on my models that i removed, so even though that didn’t fix i still appreciate the help :smile: I’m gonna try and mess around some more and see if I did anything to cause this- I can run the pre-compiled jmonkey test program, select the LevelOfDetail Generator test and the monkey from the tutorial reduces correctly, but in both my computers with the SDK i’m getting this error

You can have the normals flipped. Try to enable “backface culling” when pressing “n” on blender so you can check it.

If they are wrong, go to “edit mode” → select the the triangle → “flip direction” in the lateral menu.

I didn’t have BackFace culling enabled, but I checked that and tried what you said with two different models (an old one and a simple test model I just tmade), and I still got the problem. It also only ever generates the first level of detail regardless of how many I specify- if I go above .2 or .3 then those levels of detail don’t even show up in the models LOD dropdown box, usually just level 0 where it looks normal and level 1 where there’s just a few missing traingles


I had similar problem with LODs when I was exporting the model with xbuf exporter,

I ended up using Blender for generating LODs .

1 Like

Let’s face it, has anyone ever had good results with the official lod generator?

Yes, me!

Thanks I’ll give that a try as soon as I have a chance, I didn’t know blender had an LOD generator but it sounds like that’ll fix the issue for me hopefully

Pics or didn’t happen. And the jaime gif doesn’t count :stuck_out_tongue: